Technical Requirements for PublishPress Plugins

In order to provide you with the best and most secure software, we do have minimum requirements to run PublishPress plugins.


PHP recommendations

We highly recommend that any website using PublishPress plugins also uses PHP 5.6 or higher.

Ideally, your site should use PHP 7 or PHP 8.

WordPress officially recommends that you use PHP 7.4 as a minimum.


MySQL and Server recommendations

  • Database: MySQL version 5.7 or greater or MariaDB version 10.2 or greater.
  • Server: We recommend Apache or Nginx as the most robust and secure servers for running WordPress, but any server that supports PHP and MySQL should work.

For the official WordPress recommendations, please check here.


Does my site meet the requirements?

If you are unsure of what version of PHP and other software that your site is using, you can go use this tip:

  • Go to Tools > Site Health in your WordPress admin menu.
  • After installing the Health Check plugin, go to Dashboard, then “Health Check”. This screen will give any important news about your PHP version.
  • You can also find the specific details of your server version by clicking the “Info” tab:
  • Scroll down to the “Server” area for all the details:

Professional publishing plugins for WordPress! Get PublishPress

  • SUBSCRIBE TO OUR NEWSLETTER
  • SEARCH THIS SITE